Aller au contenu

Modern networking in Firefox with Max Inden

28 octobre 2025 · 1 h 8 min

Notes de l’épisode

Episode 11 – Modern networking in Firefox with Max Inden.

A conversation with Max Inden, Staff Software Engineer at Mozilla, about modernizing Firefox’s networking stack in Rust. We cover his work on the QUIC and HTTP/3 stack — improving UDP I/O, congestion control, and overall performance — and why QUIC matters as a fast, encrypted, and evolvable transport for HTTP/3, WebTransport, and beyond.

Learn more:

  • https://max-inden.de/ — Personal website of Max Inden
  • https://max-inden.de/post/fast-udp-io-in-firefox/ — Fast UDP I/O for Firefox in Rust — by Max Inden
  • https://archive.fosdem.org/2025/schedule/event/fosdem-2025-4229-getaddrinfo-sucks-everything-else-is-much-worse/ — getaddrinfo sucks, everything else is much worse — Talk by Valentin Gosu
  • https://github.com/mozilla/neqo — Mozilla Neqo (HTTP/3 and QUIC stack)
  • https://datatracker.ietf.org/doc/html/rfc9000 — RFC 9000 – QUIC: A UDP-Based Multiplexed and Secure Transport
  • https://datatracker.ietf.org/doc/html/rfc9114 — RFC 9114 – HTTP/3
  • https://datatracker.ietf.org/doc/html/rfc9462 — RFC 9462 – Discovery of Designated Resolvers
  • https://www.rfc-editor.org/rfc/rfc8484.html — RFC 8484 – DNS Queries over HTTPS (DoH)
  • https://datatracker.ietf.org/doc/draft-ietf-happy-happyeyeballs-v3/ — Happy Eyeballs Version 3 (Draft)
  • https://github.com/microsoft/msquic — Microsoft MsQuic
  • https://developer.mozilla.org/en-US/docs/Web/API/WebTransport — WebTransport API documentation
  • https://datatracker.ietf.org/wg/masque/about/ — MASQUE (Proxy) protocol introduction
  • https://www.ietf.org/ — Internet Engineering Task Force (IETF)
  • https://www.ietf.org/meeting/ — IETF Meetings

Rama

If you like this podcast you might also like our modular network framework in Rust: https://ramaproxy.org


Chapters

  • 00:00 Intro
  • 00:38 Introduction to Max Inden
  • 03:27 Max Inden's Journey to Mozilla
  • 06:32 The Role of IETF in Internet Design
  • 09:42 QUIC and HTTP/3 in Firefox
  • 12:27 Understanding HTTP/3 Upgrade Mechanisms
  • 15:15 Challenges with UDP and Firefox's Networking Stack
  • 18:15 Optimizing UDP I/O for Performance
  • 21:36 Cross-Platform Performance Considerations
  • 24:23 Network Drivers and Their Impact
  • 27:18 Exploring Happy Eyeballs and Connection Strategies
  • 30:07 WebTransport and Future of QUIC
  • 32:56 Contributions to Firefox and Open Source
  • 36:05 Happy Eyeballs and related
  • 56:15 Github Git Hosting
  • 57:24 Quic Usage within Firefox
  • 01:03:02 Closing Thoughts and call to Action
  • 01:06:44 Outro

Netstack.FM

  • More information: https://netstack.fm/#episode-11
  • Join our Discord: https://discord.gg/29EetaSYCD
  • Reach out to us: [email protected]

Music for this episode was composed by Dj Mailbox. Listen to his music at https://on.soundcloud.com/4MRyPSNj8FZoVGpytj.

Tous les épisodes de netstack.fm

Paramètres

Affichage

Langue

Détermine les stations affichées en premier sur la page d’accueil.

Historique

Les stations et épisodes écoutés récemment et tes dernières recherches sont seulement enregistrés dans ce navigateur.

Notifications

Un court message quand un podcast que tu suis publie un nouvel épisode. Désactive un podcast précis avec la cloche sur sa page.

Compte

Enregistrez vos favoris – dans l’app et sur le site.

Raccourcis clavier

/
Ouvrir la recherche
Espace
Lecture ou pause
← →
Dans le lecteur : 15 s en arrière, 30 s en avant (épisodes) · dans une rangée : tuile suivante
↑ ↓
Dans une rangée : cible dans la tuile
Début / Fin
Dans une rangée : première ou dernière tuile
Esc
Fermer la fenêtre ou le menu
?
Cet aperçu
En cours de lecture

Voir la station

À suivre

    Ajoutez des épisodes avec « À suivre » – ils seront lus après l'épisode en cours.